Join us on Discord at https://discord.gg/CeUpmbC :parrotsailor: All tutorials available at https://chamferzone.com/

Baking issue

Anything related to baking, texturing or sharing useful advice.
Gustavo dutra
Posts: 20
Joined: Thu Jul 26, 2018 5:52 pm
Has thanked: 8 times
Been thanked: 5 times

Fri Sep 21, 2018 4:08 pm

Hey folks how you guys doing ?

I'm trying to bake this model of mine. But i have tried 50 times already and it's not baking correctly unfortunately..... Hope you guys have any ideas. I have already checked suffix, Max Frontal/ Rear Distance, the checkboxes beneath that and weld to 0.01 as well... I'm out of options....
Attachments
Desktop Screenshot 2018.09.19 - 14.40.57.18.png
Desktop Screenshot 2018.09.19 - 14.40.57.18.png (649.66 KiB) Viewed 414 times
Desktop Screenshot 2018.09.19 - 14.40.42.09.png
Desktop Screenshot 2018.09.19 - 14.40.42.09.png (533.93 KiB) Viewed 415 times
User avatar
Laggtastic
Site Admin
Posts: 882
Joined: Thu Mar 02, 2017 12:10 am
Has thanked: 1008 times
Been thanked: 709 times

Sun Sep 23, 2018 1:16 pm

Hey there! :)

Based on these screenshots, these are the things that come up to my mind:

First image:

The jagged edges are usually caused by non-straightened edges in your unwrap. I can't see you're unwrap so I'm not sure if you have them straightened or kept the shape as we see it here?

Sometimes it's also a matter of at what resolution you have your Substance Painter viewport set to. Example: Generally you watch it in 2K, but if you are going to create renders with 4K textures you might want to double check how it looks in 4K inside your viewport? :) Also ask yourself the question if it would be very visible inside your renders/ingame, if it's not you can leave it as it is. Depending on your wishes :)

Second image:

Looks like the artifacts that appear when geometry is to close to eachother with the current max frontal/rear distances. In narrow areas this is something that happens sometimes.
I guess the "3 boxes" are the same object? Make sure to save your file (eventually as a new one) for backup and then you could try to detach the lower one, also adjust the unwrap if required & run the Textools "smoothing groups from UV shells" operation if you do so. See if that fixes it :)
Gustavo dutra
Posts: 20
Joined: Thu Jul 26, 2018 5:52 pm
Has thanked: 8 times
Been thanked: 5 times

Mon Sep 24, 2018 1:32 pm

Thanks for replying, i appreciate a lot really. I have used smoothing groups from UV shells and some parts of my model got black, i think this might be the issue in here.
Attachments
Desktop Screenshot 2018.09.24 - 10.24.56.58.png
Hope you can clearly see the UV.
Desktop Screenshot 2018.09.24 - 10.24.56.58.png (190.89 KiB) Viewed 379 times
Desktop Screenshot 2018.09.24 - 10.25.07.97.png
black parts after using smoothing groups from UV shells.
Desktop Screenshot 2018.09.24 - 10.25.07.97.png (340.15 KiB) Viewed 380 times
Gustavo dutra
Posts: 20
Joined: Thu Jul 26, 2018 5:52 pm
Has thanked: 8 times
Been thanked: 5 times

Thu Sep 27, 2018 7:41 pm

I found out why it was that way. It was UV problems, i just added one face underneath. However i found some similar issues.
Attachments
Desktop Screenshot 2018.09.27 - 16.41.15.04.png
Desktop Screenshot 2018.09.27 - 16.41.15.04.png (589.85 KiB) Viewed 347 times
Desktop Screenshot 2018.09.27 - 16.35.58.71.png
Desktop Screenshot 2018.09.27 - 16.35.58.71.png (635.2 KiB) Viewed 347 times
User avatar
Laggtastic
Site Admin
Posts: 882
Joined: Thu Mar 02, 2017 12:10 am
Has thanked: 1008 times
Been thanked: 709 times

Sun Sep 30, 2018 4:14 pm

Glad to read you found out about the inital problem :)
Regarding the new issues:

The upper image seems to bake ok but the jagged edges appear probably because the UV island doesn't have straightened edges (not sure which shells they are in the unwrap).

The unwrap, based on the earlier post of yours, seems to have a lot of open space between the shells. Not sure if this object shares the Unwrap space with other objects, but if not: I suggest to use your UV space more efficiently so you can scale up your UV shells resulting in less AA-issues :) Talking about Anti-Aliasing: What settings did you use during the bakes for this?

Second image seems to be an issue where the lowpoly mesh doesn't get information from the highpoly model; Are these shells still inside the 0-1 UV space?
If they are, you might want to run Textool's Smoothing Groups from UV shells function and also double check if the highpoly model actually is aligned correctly with the lowpoly mesh which you unwrapped.
Gustavo dutra
Posts: 20
Joined: Thu Jul 26, 2018 5:52 pm
Has thanked: 8 times
Been thanked: 5 times

Sun Sep 30, 2018 6:45 pm

Thanks a lot man, but i think it 'll be way better if a send to you my model. Can i send to you so you can take a better look ? I have already asked for a lot of other guys about this, and all the hints doesn't seems to work....
User avatar
Laggtastic
Site Admin
Posts: 882
Joined: Thu Mar 02, 2017 12:10 am
Has thanked: 1008 times
Been thanked: 709 times

Mon Oct 01, 2018 4:33 am

Gustavo dutra wrote:
Sun Sep 30, 2018 6:45 pm
Thanks a lot man, but i think it 'll be way better if a send to you my model. Can i send to you so you can take a better look ? I have already asked for a lot of other guys about this, and all the hints doesn't seems to work....
Sure thing ! :)

I will look into it in the evening as I'm not able to do that at work. Also, make sure you send a 2016 3Ds max version in case you use a newer version^^

You can share it by uploading it to a fileshare system such as Dropbox, and send me a link to that folder. You can send me a PM if you prefer that instead of posting it public here :)
Gustavo dutra
Posts: 20
Joined: Thu Jul 26, 2018 5:52 pm
Has thanked: 8 times
Been thanked: 5 times

Tue Oct 02, 2018 12:37 pm

Alright :] Thanks a lot man, thanks for you support i really really apreciate. Here's the link https://www.dropbox.com/s/nalgio6w138gr ... 6.max?dl=0
User avatar
Laggtastic
Site Admin
Posts: 882
Joined: Thu Mar 02, 2017 12:10 am
Has thanked: 1008 times
Been thanked: 709 times

Thu Oct 04, 2018 4:23 am

Gustavo dutra wrote:
Tue Oct 02, 2018 12:37 pm
Alright :] Thanks a lot man, thanks for you support i really really apreciate. Here's the link https://www.dropbox.com/s/nalgio6w138gr ... 6.max?dl=0
Awesome^^ I will downlad the file after work today as yesterday evening turned out quite different than I expected.. :( Will update you when I inspected your file :thumbsup_dude:
Gustavo dutra
Posts: 20
Joined: Thu Jul 26, 2018 5:52 pm
Has thanked: 8 times
Been thanked: 5 times

Thu Oct 04, 2018 4:18 pm

Alright, hope you can find my mistakes :] Have a good day at work.
Post Reply