Join us on Discord at https://discord.gg/CeUpmbC :parrotsailor: All tutorials available at https://chamferzone.com/

Substance Slowing down PC

Whatever doesn't fit in the above categories. Extra points for keeping it SFW and politics free.
Post Reply
DavidFL
Posts: 23
Joined: Sun Jan 14, 2018 12:02 pm
Has thanked: 9 times
Been thanked: 18 times

Fri Jan 19, 2018 6:05 pm

Hey.

posted this on the allegorithmic forum the other day but it seems noone knows the answer or maybe their support is just busy.
So i post this here, maybe someone has an idea of what i can do to solve this.

Here you go.

After using Substance Painter for a while, my pagefile.sys is getting more and more full which eventually slows down my computer entirely up to a point where a restart is the only option.

I followed the link in the warning when starting SP, that tells you to increase virtual memory.
Been there, done that, set my pagefile to 16384 MB. I am running 16 GB of Ram.
Everything seemd fine for a while, but i noticed my computer getting slower and slower over time.
I checked the Ram usage an it was at 99%
I checked the pagefile and it was at around 16 GB.
So yeah, i ran out of physical and virtual memory. I am not sure why tho.
Does SP really need more than 16 GB of Ram to be used or does windows 10 not know how to remove unnecessary data from the pagefile on the fly?

But its even worse.
So i closed down SP but my Ram usage only dropped from 99% to around 85%. But thats it. 85% with nothing else than windows running. Usually i am at around 20% after a fresh start.
Also, in my pagefile settings, it tells me a recommended size of 2938MB
Can i somehow avoid increasing the pagefile to 16+GB to use substance painter without it crashing all day long ?
Or is it something else that is causing the issue?

This bugs me for a few days now and sadly i couldn't find any usefull informations on the web.
any help is much appreciated, as i cant get things done.
User avatar
Laggtastic
Site Admin
Posts: 882
Joined: Thu Mar 02, 2017 12:10 am
Has thanked: 1008 times
Been thanked: 709 times

Wed Jan 24, 2018 10:21 am

Hey David,

Got to admit: At this time I have no idea where the issue comes from, I have 8 GB RAM and experience the same issue, so I know it's super frustrating especially when working with big files.
Right now I'm kinda packed up with work, but at least wanted to let you know that I will look into it when I can, to see if I perhaps find some solution anywhere .. :thinking:

If I find anything interesting / solution I will post it here.
DavidFL
Posts: 23
Joined: Sun Jan 14, 2018 12:02 pm
Has thanked: 9 times
Been thanked: 18 times

Wed Jan 24, 2018 4:55 pm

Hey Laggtastic

Sry to hear you suffer from this experience aswell.
I might have found a solution tho, that seems to have solved the problem for me, maybe it will help you too.
It seems to be a memory leak related to some Razer software.

Credit belongs to a reddit user called 'TheObsidianPickaxe'



I hope it helps you too and is more than just a fleeting star :thumbsup:
Post Reply